Back to overview
Degraded

Premium node is down, EclipseNode is looking into it

Dec 03 at 05:00pm GMT

Resolved
Dec 03 at 06:28pm GMT

Our node is back up

Created
Dec 03 at 05:00pm GMT

The DE node is down.